Partial degraded system performance
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Mar 17, 2018 - 00:17 PDT
Monitoring
We've addressed the underlying issue and are currently processing through the backlog on workflows, user updates and campaign analytics. We expect this to clear up in the next few hours.
Posted Mar 16, 2018 - 18:08 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 16, 2018 - 16:08 PDT
Investigating
We're currently investigating issues that involve workflows, user updates, and campaign analytics. Some customers may be experiencing delays in processing.
Posted Mar 16, 2018 - 13:50 PDT