Degraded Back-end Processing Performance
Incident Report for Iterable
Resolved
Incident resolved.
Posted Feb 23, 2017 - 12:40 PST
Identified
We are currently experiencing high workflow usage that might affect lists, workflows, and campaign speed; we've identified the root cause and are working to resolve.
Posted Feb 23, 2017 - 12:13 PST