Partial Degraded Processing
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Nov 28, 2017 - 16:57 PST
Investigating
Sending and List Uploads are experiencing delays for some customers.
Posted Nov 28, 2017 - 15:55 PST