Reopening - Some Customers Experiencing Email Links Timing Out or Slow to Load
Incident Report for Iterable
Resolved
We have resolved this incident and confirmed the links are now redirecting properly and API calls are returning successful 200 responses. Please reach out to support@iterable.com or to your CSM if you have any questions.
Posted Jun 13, 2018 - 17:34 PDT
Monitoring
Email links and API calls should now be processing properly again. We are monitoring the queues that handle these requests to ensure there are no further issues. Thank you for your patience.
Posted Jun 13, 2018 - 16:11 PDT
Identified
We have identified a fix that would solve the link time out issues as well as the API errors. We will update again before 4:00 pm PDT. Thank you for your patience.
Posted Jun 13, 2018 - 15:13 PDT
Update
Our engineering team is continuing to investigate root cause and are working to resolve the link time out issues as well as the API errors. We will update again by 3:00 pm PDT. Thank you for your patience.
Posted Jun 13, 2018 - 14:31 PDT
Investigating
We have received reports from our customers that there are still links that are not resolving within emails. Our engineering team is continuing to investigate this. The next update will be before 2:15 PM PST.
Posted Jun 13, 2018 - 13:36 PDT
This incident affected: Global API and Global Links.