Degraded Performance - Workflows inaccessible to some customers
Incident Report for Iterable
Resolved
This incident has been resolved. All customers are able to access their workflows at this time.
Posted Mar 08, 2018 - 12:15 PST
Identified
We've investigated and identified an issue with accessing workflows. A small subset of customers are unable to access their workflows.
Posted Mar 08, 2018 - 09:10 PST