Degraded Back-end Processing Performance
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Apr 27, 2017 - 17:21 PDT
Investigating
We are currently experiencing slowdowns in back-end processing that may be impacting workflow processing speed, list uploads, analytics, and experiment analytics. We are investigating the root cause now.
Posted Apr 27, 2017 - 13:45 PDT