Degraded Back-end Processing Performance
Incident Report for Iterable
Resolved
We have resolved this issue; please be patient as previous update calls in the queue are being processed and may take a few minutes to show up.
Posted Mar 13, 2017 - 14:11 PDT
Investigating
We are experiencing back-end processing delays which are impacting user profile and subscription updates for both our web app and API.
Posted Mar 13, 2017 - 13:37 PDT