Some Customers Experiencing Email Links Timing Out or Slow to Load
Incident Report for Iterable
Resolved
We have resolved this incident and confirmed the links are now redirecting properly and API calls are returning successful 200 responses. We apologize for the inconvenience. Please reach out to your CSM for root cause analysis.
Posted Jun 13, 2018 - 13:04 PDT
Update
Our engineers are continuing to work on resolving the API 5XX error issues and links timing out. We don't yet have an estimated time for resolution and will update again by 12:45 pm PDT. Thank you for your patience. If you have any additional questions, please contact us at support@iterable.com
Posted Jun 13, 2018 - 12:10 PDT
Identified
Our engineering team is continuing to work on the link timeouts and api 5XX error issues. We don't yet have an estimated time for resolution, but we will update again by 11:45am PDT. If you have any additional questions, please contact us at support@iterable.com
Posted Jun 13, 2018 - 11:12 PDT
Update
Some customers are also experiencing issues with 5XX API errors. We are investigating if these errors are correlated to the link time outs, but our team is still investigating a root cause. Next update by 11 am PDT. Thank you for your patience.
Posted Jun 13, 2018 - 10:29 PDT
Investigating
Some customers are experiencing issues with email links timing out or slow to load. Our San Francisco-based engineering team is now working to fix this. We will provide the next update by 10:20 am Pacific Time.
Posted Jun 13, 2018 - 09:51 PDT
This incident affected: Global API and Global Links.