Degraded Back-end Processing Performance
Incident Report for Iterable
Resolved
Incident resolved.
Posted Feb 17, 2017 - 14:21 PST
Investigating
We are currently experiencing slowdowns in back-end processing that may be impacting workflow processing speed and analytics and are investigating the root cause now.
Posted Feb 17, 2017 - 10:14 PST