We have observed no recurrence since 10/10. The issue now is resolved. Please feel free to reach out to support for further questions.
Posted Oct 14, 2025 - 13:34 PDT
Update
There were no recurrences observed today. We will continue to monitor for recurrence.
Next Update: We will provide our next status update before 12:00 PM PT tomorrow.
Posted Oct 13, 2025 - 19:04 PDT
Update
There were no recurrences observed from October 10th afternoon to October 13th morning. We will continue to monitor until the end of the day.
Next Update: We will provide our next status update before 5:00 PM PT.
Posted Oct 13, 2025 - 09:51 PDT
Update
There are no further recurrences after the fix was deployed today. We will continue to monitor the affected systems over the weekend.
Posted Oct 10, 2025 - 15:30 PDT
Monitoring
We have successfully deployed the fix and will start monitoring for recurrences.
Next Update: We will provide our next status update before 3:00 PM PT.
Posted Oct 10, 2025 - 11:30 PDT
Update
We worked with the vendor to fix this issue. The vendor recommended an approach to prevent additional data loss. We will apply the fix and monitor the affected systems for recurrence.
Next Update: We will provide our next status update before 12:00 PM PT.
Posted Oct 10, 2025 - 10:15 PDT
Investigating
The fix applied by our key vendor did not work. The impact is that a limited amount of exit rule data was lost. We began observing a recurrence of the same limited data loss on October 10th, 2025, at 7:00 AM PST. We are working with the vendor to investigate further.
Next Update: We will provide our next status update before 10:00 AM PT.
Posted Oct 10, 2025 - 08:25 PDT
Update
There is no further recurrence of the infrastructure issue from our key vendor. We will continue to monitor the affected infrastructure for recurrence.
Next Update: We will provide our next status update before 9:00 AM PT on October 10, 2025.
Posted Oct 09, 2025 - 15:23 PDT
Update
The key vendor has confirmed the defect on their side and has taken steps to prevent recurrence. We will continue to closely monitor the affected systems.
We will provide our next status update before 3:00 PM PT.
Posted Oct 09, 2025 - 12:36 PDT
Monitoring
The engineering team has successfully identified the root cause of this incident: a major infrastructure issue experienced by one of our key vendors.
We are actively partnering with the vendor to ensure the issue is fully resolved and to prevent any future impacts to our services.
Next Update: We will provide our next status update before 12:00 PM PT.
Posted Oct 09, 2025 - 08:13 PDT
Update
We are continuing to investigate this issue.
Posted Oct 09, 2025 - 07:54 PDT
Investigating
Any visitor who entered a delay tile longer than 24hrs that received an exit match post 8:30 PM PST yesterday October 8th, with no subsequent updates to their exit rules may continue to experience incorrect journey exits until October 10th 8:30 PM PST. Any user receiving an exit rule update since then will not be impacted and will exit correctly. Overall this represented less than 1% of total users within Journeys with the final number being much lower due to many users in delays receiving exit rule updates since the beginning of the impact window which negated the issue. For those customers impacted the most our teams are reaching out to them to discuss next steps. We wil provide the next update before 10AM PT.