Metadata store running slowly
Incident Report for Iterable
Resolved
All metadata store services are now fully-functional. Thank you for your patience. If you have any concerns or are still seeing metadata store issues, please contact us at support@iterable.com
Posted Jan 10, 2019 - 14:21 PST
Monitoring
The data update for the metadata store continues, and is actually going much faster now, due to some optimizations made by our engineers. We now expect this to be complete by about 3pm Pacific Time. We have also determined that only a subset of organizations using metadata store were impacted, not everyone. The next update should be once the data update is complete.
Posted Jan 10, 2019 - 13:58 PST
Update
We're continuing to work on updating the data in our metadata store. The transfer rate is a little slower than expected, so our current ETA for completion is 5pm Pacific Time. We'll have another update by 2pm Pacific Time. Thanks for your patience.
Posted Jan 10, 2019 - 12:01 PST
Identified
We are currently working on resolving a situation in which the metadata store system is in a degraded state. Specifically, any updates made after approximately 7am Pacific Time this morning will not yet show up. If they were new data, the data will not be available to use, causing outbound messages that are trying to use that data to fail. If they were updates to existing data, the existing data will be used instead.

Campaigns and workflows that do not use the metadata store are unaffected.

Our engineering team has identified that this issue was caused by a storage partition becoming inactive - we're still working on understanding why. The result of this failure was that the metadata store needed to be rebuilt. This process is ongoing, and is expected to take until about 4pm Pacific Time this afternoon. We'll provide an update on this process within the next 90 minutes.
Posted Jan 10, 2019 - 10:39 PST
This incident affected: Global API.