Delays in processing System Webhooks

Incident Report for Iterable

Resolved

This incident has been resolved.
Posted Oct 26, 2024 - 12:35 PDT

Monitoring

System webhook backlog is depleted and the incident is resolved.
Posted Oct 26, 2024 - 12:30 PDT

Identified

The code fix for the slowness of System webhooks is deployed. Currently the queue is depleting. This could take several hours to deplete the backlog completely. During this time the performance will be degraded. Next update at 6pm PST.
Posted Oct 25, 2024 - 14:00 PDT
This incident affected: Global System Webhooks.