Segmentation page intermittent slowness
Incident Report for Iterable
Resolved
The issue has been resolved.
Posted Nov 25, 2024 - 12:18 PST
Update
The issue has been mitigated. The engineering team continues to monitor systems. If you are still seeing any impact please reach out to support@iterable.com
Posted Nov 25, 2024 - 11:06 PST
Monitoring
The issue has been mitigated. The engineering team will continue monitoring systems and we will update at 11:30am PT or sooner.
Posted Nov 25, 2024 - 09:47 PST
Identified
The issue has been identified and fix has been implemented. The engineering team will continue monitoring systems and we will update at 10:15am PT or sooner.
Posted Nov 25, 2024 - 09:25 PST
Investigating
Intermittent slowness observed on segmentation page. The engineering team is currently investigating and we will update at 9:45am PT.
Posted Nov 25, 2024 - 09:07 PST