app.iterable.com currently unreachable
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Oct 30, 2023 - 13:30 PDT
Investigating
app.iterable.com is reachable again. Thank you for your patience.
Posted Oct 30, 2023 - 13:26 PDT
This incident affected: Global Web Application.