Proof Send Functionality Degraded

Incident Report for Iterable

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 11:50 PDT

Monitoring

The engineering team has implemented a fix and proofs are now successfully sending. We will continue to monitor. Next update at 12:00 PST or earlier.
Posted Mar 16, 2026 - 10:09 PDT

Investigating

We have been alerted to an issue where proofs sends are not being sent as expected as of 9:00 am PT. Iterable Engineers are actively investigating the issue. Next update by 11:00 am PT or sooner.
Posted Mar 16, 2026 - 09:18 PDT
This incident affected: Global Proof Sends.