Mailgun has Degraded Performance

Incident Report for Iterable

Resolved

This incident has been resolved.
Posted May 19, 2025 - 15:28 PDT

Update

Mailgun has implemented a fix and is in Monitoring status
Posted May 19, 2025 - 14:54 PDT

Monitoring

We are monitoring the affect of the mailgun degradation
Posted May 19, 2025 - 14:43 PDT

Investigating

Mailgun is reporting degraded performance across their application https://status.mailgun.com/. We are monitoring mailgun and their performance.
Posted May 19, 2025 - 14:42 PDT