Resolved: api-hightraffic Errors in Europe

Incident Report for Iterable

Resolved

Status: Resolved

Between 3:50 pm and 5:55 pm CEST customers in our EUDC (European Data Center) region may have experienced an increased 5xx error rate, approximately 10-15%, when making api requests. This issue was isolated to Europe; no impact was observed in other regions. If customers have any questions if they were impacted please reach out to support@iterable.com
Posted Sep 11, 2025 - 09:37 PDT
This incident affected: Global API Success.