Website Degraded
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 12:33 PST
Monitoring
Iterable Engineering has confirmed that we've recovered from the errors that were previously noted as reaching app.iterable.com. Users should be seeing platform speeds return to normal. Engineering is continuing to monitor and put preventative measures in place, but if you are still seeing any impact with Iterable pages loading slowly please reach out to support@iterable.com
Posted Nov 20, 2024 - 08:51 PST
Investigating
From 4:45 AM to 5:45 AM PT, we saw errors and slowness reaching app.iterable.com. Accessing all areas of the platform may have been met with slow loads, but sends and logins are not affected. The engineering team is currently investigating and we will update at 8:30am PT.
Posted Nov 20, 2024 - 07:34 PST
This incident affected: Global Web Application.