API issues: Bulk APIs, ListSubscribe and ListUnsubscribe
Incident Report for Iterable
Resolved
The downstream infrastructure issues have been resolved and all API endpoints are ingesting properly. We will endeavor to identify what API calls might have been impacted during the outage and will be in touch with any customers associated with those calls. Thank you for your patience.
Posted Jun 19, 2019 - 17:55 PDT
Identified
This afternoon from approximately 4:05pm Pacific Time until 4:25pm, calls to the Bulk API endpoint, as well as calls to ListSubscribe and ListUnsubscribe, were failing, due to a downstream issue with our message processing infrastructure. This would also have impacted list uploads. The situation has now been mitigated, and depending upon the client-side retry logic, calls may yet process successfully. We are working to identify a list of calls that failed and connect with impacted customers. We are also continuing to monitor the infrastructure which was responsible to ensure it does not re-occur.

Next update by 6pm Pacific Time.
Posted Jun 19, 2019 - 16:54 PDT
This incident affected: Global API.