WhatsApp Messaging Delays and Failures

Incident Report for Iterable

Resolved

The issue affecting WhatsApp messaging has been resolved. Customers should no longer experience delays or failures sending WhatsApp messages. We will continue to monitor to ensure service remains stable.
Posted Jun 12, 2026 - 10:18 PDT

Identified

We are aware of an issue affecting WhatsApp messaging. Some customers may experience delays or failures sending WhatsApp messages. This appears to be caused by an external service disruption, and we are monitoring for updates. We will share another update by 1pm PST or sooner if new information becomes available.
Posted Jun 12, 2026 - 09:24 PDT