Users are having issues accessing and saving journeys and campaigns.
Incident Report for Iterable
Resolved
The Engineering team resolved the underlying issues. If you are still experiencing issues, please contact the Iterable support team for further assistance.
Posted Aug 30, 2023 - 18:22 PDT
Monitoring
The Engineering team implemented a fix, and we have recovered from the service degradation. We will continue monitoring the service for any additional degradation issues and provide another update at 6:00 PM PST.
Posted Aug 30, 2023 - 17:15 PDT
Investigating
We detected that campaigns and templates cannot be accessed or saved. The outage is intermittent and the engineering team is working on restoring the service. The next update is at 5:00 PM PST.
Posted Aug 30, 2023 - 16:13 PDT
This incident affected: Global Web Application.