EU platform slowness and gateway errors

Incident Report for Iterable

Resolved

We completed our monitoring and there are no further issues. The observed customer impact window was approximately 9:25 a.m.–11:13 a.m. EDT.
Posted Sep 10, 2026 - 10:16 PDT

Monitoring

The intermittent platform issues have been mitigated and there is currently no ongoing customer impact. The observed customer impact window was approximately 9:25 a.m.–11:13 a.m. EDT. We will continue to monitor the issue.
Posted Sep 10, 2026 - 09:09 PDT

Investigating

We're currently investigating an issue for EU customers with platform slowness, intermittent 502/503 Gateway errors, and Journey changes failing to save
Posted Sep 10, 2026 - 07:53 PDT
This incident affected: Global Web Application, Global API Success, and Global Journey Processing.