API ingestion failure

Incident Report for Iterable

Resolved

The issue has been resolved by rotating the expired certificates, and the previously observed ingestion lag has subsided.
Posted Jan 26, 2024 - 22:39 PST

Identified

The ingestion delay is still ongoing, and the team is in the process of updating the expired certificates.
Posted Jan 26, 2024 - 22:12 PST

Update

We are continuing to investigate this issue.
Posted Jan 26, 2024 - 21:55 PST

Investigating

Beginning at approximately 7:44 PM PST customers may have experienced API ingestion delay across multiple endpoints. As of approximately 8:41 pm PST here we have seen SSL handshake failure and team is investigating to resolve the issue. If you have any questions or believe you were impacted during this incident window please reach out to support@iterable.com or your customer success manager
Posted Jan 26, 2024 - 20:47 PST
This incident affected: Global API Success and Global API Ingestion.