Email Send Failures
Incident Report for Iterable
Resolved
Our message backlog has caught and cleared. If you have any further questions please reach out to support@iterable.com or your Customer Success Manager.
Posted Jun 16, 2022 - 06:50 PDT
Update
We will continue to monitor our message backlog. If you have any further questions please reach out to support@iterable.com or your account manager.
Posted Jun 15, 2022 - 21:10 PDT
Monitoring
Engineering has completed deploying a fix to mitigate the send delays and we are seeing an improvement as we process through the message backlog. We will continue to watch closely so that no further issues occur. Next update 9 PM PDT or sooner.
Posted Jun 15, 2022 - 19:47 PDT
Update
We are continuing to investigate the underlying cause and working with a downstream provider that handles our send services. Both scheduled sends and workflow sends are enqueued and will be delayed until a fix is implemented. Our next update will be at 7:30 PM PDT or sooner.
Posted Jun 15, 2022 - 18:29 PDT
Investigating
We are currently investigating errors relating to email send failures beginning at approximately 5:30 PM PDT. This includes triggered and scheduled campaign sends as well as proofs. Next update by 6:30 PM PDT or sooner.
Posted Jun 15, 2022 - 17:46 PDT
This incident affected: Cluster 5 (Email Sends), Cluster 6 (Email Sends), Cluster 8 (Email Sends), Cluster 9 (Email Sends), Cluster 10 (Email Sends), Cluster 11 (Email Sends), Cluster 12 (Email Sends), Cluster 13 (Email Sends), Cluster 14 (Email Sends), Cluster 15 (Email Sends), Cluster 16 (Email Sends), Cluster 17 (Email Sends), Cluster 18 (Email Sends), Cluster 19 (Emails Sends), Cluster 20 (Email Sends), and Cluster 21 (Email Sends).