Workflow delays
Incident Report for Iterable
Resolved
All issues involving workflow processing have been resolved, and we will continue to monitor. Thank you for your patience. Please reach out to your account manager or support if you have further questions.
Posted Sep 13, 2019 - 15:00 PDT
Update
Workflow processing is improving and our team is continuing to monitor. Next update at 3 pm PDT
Posted Sep 13, 2019 - 13:36 PDT
Monitoring
The engineering team has identified the source of the issue. Workflows are processing again. Next update at 1pm PDT.
Posted Sep 13, 2019 - 12:03 PDT
Investigating
A small subset of customers are experiencing a delay in workflow processing. Our engineering team is actively investigating this. We appreciate your patience. Next update at 12pm PDT.
Posted Sep 13, 2019 - 11:17 PDT