Timeouts on User Update API Endpoints

Incident Report for Iterable

Resolved

All API issues are now resolved and the user update endpoints are fully operational. If you continue to experience any issues, please contact Support.
Posted Sep 22, 2026 - 12:58 PDT

Monitoring

We are continuing to investigate the issue but are seeing positive signs of recovery. API endpoints for user updates are back to normal success rates. Next update at 3:45 PM EDT or sooner.
Posted Sep 22, 2026 - 12:14 PDT

Investigating

We are currently investigating an issue leading to slowness and timeouts across all API user update endpoints beginning at 2:45 PM EDT. Next update at 3:15 PM EDT
Posted Sep 22, 2026 - 12:02 PDT
This incident affected: Global API Success.