Degraded performance on C16
Incident Report for Iterable
Resolved
Our engineering team has verified Cluster 16 has recovered. The issue is now resolved. Should you experience issues, please contact support at support@iterable.com.
Posted Jan 11, 2024 - 11:28 PST
Monitoring
The engineering team has been able to return Cluster 16 to a healthy state. All operations on the cluster should be fully recovered at this point. The team will continue to monitor. Next update at 11am PT or sooner
Posted Jan 11, 2024 - 09:34 PST
Update
The engineering team was able to get C16 to a healthier state, and the cluster health continues to improve. Customers may still experience some occasional slowness in viewing lists and campaign insight metrics in the app and slower campaign and journey processing. The team will continue to investigate. Next update at 1/11 9:30am PT or sooner.
Posted Jan 10, 2024 - 19:07 PST
Update
The engineering team is continuing to investigate the root cause of the C16 degradation and is looking for paths to remediation. Next update at 7pm PT or sooner.
Posted Jan 10, 2024 - 18:01 PST
Update
The engineering team is continuing to investigate the root cause of the C16 degradation and is looking for paths to remediation. Next update at 6pm PT or sooner.
Posted Jan 10, 2024 - 17:11 PST
Update
The engineering team is continuing to investigate the root cause of the C16 degradation and is looking for paths to remediation. Next update at 4pm PT or sooner.
Posted Jan 10, 2024 - 14:58 PST
Update
The engineering team is continuing to investigate the root cause of the C16 degradation and is looking for paths to remediation. Next update at 3pm PT or sooner.
Posted Jan 10, 2024 - 14:09 PST
Update
The engineering team is continuing to investigate the root cause of the C16 degradation and is looking for paths to remediation. Next update at 2pm PT or sooner.
Posted Jan 10, 2024 - 13:00 PST
Update
The engineering team is continuing to investigate the root cause of the C16 degradation and is looking for paths to remediation. Next update at 1pm PT or sooner.
Posted Jan 10, 2024 - 12:01 PST
Update
The engineering team is continuing to investigate the root cause of the C16 degradation and is looking for paths to remediation. Next update at 12pm PT or sooner.
Posted Jan 10, 2024 - 11:02 PST
Investigating
The engineering team identified degraded performance on C16 starting January 9th, at around 11pm PT. We expect customers have experienced slowness in viewing lists and campaign insight metrics in the app and slower campaign and journey processing from that time. The engineering team is continuing to investigate the root cause of this degradation. Next update at 11am PT or sooner.
Posted Jan 10, 2024 - 09:57 PST
This incident affected: Cluster 16 (Email Sends, Workflow Processing, Push Sends, SMS Sends, User Updates, List Uploads, User Deletions).