Iterable live chat support outage
Incident Report for Iterable
Resolved
Our provider informs us that the issues with live chat appear to be resolved, and the platform is now working. If you have any issues opening a chat, please let us know at support@iterable.com
Posted Sep 21, 2020 - 10:33 PDT
Investigating
For customers who have access to live chat support within Iterable, the chat widget is currently not working. This is due to issues being experienced by a downstream provider. We have opened a case with them and it is being investigated. In the meantime, if you need to reach support, please email us at support@iterable.com and we'll get right back to you. We will post a follow-up update once the issue is resolved.
Posted Sep 21, 2020 - 09:42 PDT
This incident affected: Global Web Application.