Small subset of customers on c22 experiencing delays with journey processing, list uploads, and event processing.
Incident Report for Iterable
Resolved
This incident has been resolved.
Posted Jun 28, 2024 - 13:04 PDT
Investigating
We have received customer reports of delays with journey processing, list uploads, and event processing on cluster 22. The Engineering team is working on remediating these delays. Next update at 1 PM PT or sooner.
Posted Jun 28, 2024 - 11:45 PDT
This incident affected: Cluster 22 (Workflow Processing, List Uploads).