Data Ingestion Delays
Incident Report for Iterable
Resolved
We have not seen any further ingestion delays. The root cause has been identified as an error in a code deployment this morning, and the engineering team is working on adding additional tests to ensure that this error is caught in the future. Thank you for your patience.
Posted Aug 13, 2019 - 16:30 PDT
Update
We are no longer experiencing any ingestion delays. We are continuing to monitor to make sure that the delay does not return.
Posted Aug 13, 2019 - 13:50 PDT
Monitoring
Our engineering team has implemented a fix for this issue, and the delay is starting to subside. We are monitoring to ensure that delay does not begin to accumulate again. Next update at 1:30pm PDT.
Posted Aug 13, 2019 - 12:31 PDT
Identified
Our engineering team has identified the issue and is working on a code fix to resolve it. Next update at 12:50pm PDT.
Posted Aug 13, 2019 - 11:43 PDT
Update
We are continuing to investigate the cause of the ingestion delay. Next update at 11:50am PDT.
Posted Aug 13, 2019 - 10:54 PDT
Investigating
We are currently experiencing delays with data ingestion of up to 40 minutes. It is impacting event tracking, user updates, and CSV uploads. Our engineering team is working diligently to resolve this issue. Next update by 10:50am PDT.
Posted Aug 13, 2019 - 09:48 PDT
This incident affected: Global Analytics Processing.