Ingestion Delays Across Multiple Clusters
Incident Report for Iterable
Resolved
Ingestion has caught up on all clusters with no further delays on message sends, list uploads, workflow triggers, or event processing. If you have any questions please reach out to your account manager or email support@iterable.com
Posted Sep 05, 2022 - 13:59 PDT
Monitoring
Our engineering team has identified the underlying issue and deployed a fix to the impacted clusters. Ingestion processing rates have picked up and we are working through the backlog of messages and events. Impacted customers should start seeing event processing catching up and ultimately return to normal over the next hour. We will continue monitoring for any other issues with the next update at 2 PM PDT or sooner
Posted Sep 05, 2022 - 13:08 PDT
Investigating
Our platform is currently experiencing data ingestion delays across multiple clusters. This is causing delays of various degrees across areas such as workflow triggers, email sends, users updates, and list uploads. No data is being dropped, only delayed and will ultimately be processed. Our engineering team is investigating the cause and taking steps to improve processing speeds as we work through the backlog of events. Next update will be at 1 PM PDT or sooner.
Posted Sep 05, 2022 - 11:05 PDT
This incident affected: Global Web Application and Global API.