C21 Journey Delays
Incident Report for Iterable
Resolved
The original journey performance issues that triggered this incident have now been resolved. If you experience further journey performance issues, please contact our Support team.
Posted Dec 01, 2023 - 14:49 PST
Identified
A problematic Journey was identified and suspended. Performance is recovering, and our team will continue to monitor. Next update at 3:00PM PST.
Posted Dec 01, 2023 - 14:04 PST
Investigating
Customers on cluster 21 may be experiencing delays with journey performance. Our engineering team is working to identify the cause. Emails are still being processed. Next update at 2:00PM PST.
Posted Dec 01, 2023 - 13:20 PST
This incident affected: Cluster 21 (Workflow Processing).