Email sends not going out.
Incident Report for Iterable
Resolved
Email sends and proofs are working as expected now.

If you have further questions please contact your CSM or contact support at support@iterable.com
Posted May 28, 2021 - 07:58 PDT
Monitoring
We have received reports from some customers that email sends and proofs are not sending right now. Our Engineering team is currently investigating.

Next update at 12 pm EDT.
Posted May 28, 2021 - 07:07 PDT
This incident affected: Cluster 6 (Email Sends), Cluster 11 (Email Sends), Cluster 12 (Email Sends), Cluster 14 (Email Sends), and Cluster 16 (Email Sends).