Email send failures and delays
Incident Report for Iterable
Resolved
Our backlog is caught up we are moving this incident to resolved. For any questions, please reach out to your CSM or to Support.
Posted Aug 23, 2022 - 17:52 PDT
Monitoring
The backlog of emails continues to be processed. Next update at 7:30pm PT.
Posted Aug 23, 2022 - 17:21 PDT
Identified
The Engineering team has identified the cause of the send failures, and sends are now going out. Emails that failed to send on SES will be retried. Emails will continue to be delayed as the backlog gets processed. Next update at 5:15pm PT
Posted Aug 23, 2022 - 16:17 PDT
Update
The Engineering team continues to investigate the cause of email send failures. We are now experiencing email delays across all ESPs. Next update at 5pm PT.
Posted Aug 23, 2022 - 16:00 PDT
Update
Our engineering continues to investigate the cause of the email send failure for clients using shared IPs on SES. Next update at 4 pm PT
Posted Aug 23, 2022 - 15:01 PDT
Investigating
We have received reports that customers using shared IPs on SES are seeing email send failures. Customers using other third party dedicated IPs are not impacted. Our engineering team is currently investigating and the next update will be at 3 PM PDT.
Posted Aug 23, 2022 - 14:19 PDT
This incident affected: Cluster 21 (Email Sends), Cluster 8 (Email Sends), Cluster 5 (Email Sends), Cluster 14 (Email Sends), Cluster 6 (Email Sends), Cluster 23 (Email Sends), Cluster 20 (Email Sends), Cluster 22 (Email Sends), Cluster 13 (Email Sends), Cluster 17 (Email Sends), Cluster 15 (Email Sends), Cluster 11 (Email Sends), Cluster 16 (Email Sends), Cluster 12 (Email Sends), Cluster 19 (Emails Sends), Cluster 18 (Email Sends), Cluster 10 (Email Sends), and Cluster 9 (Email Sends).