Unable to Save Templates
Incident Report for Iterable
Resolved
There have been no new reports of issues with saving templates. This incident is now resolved. If you are still experiencing issues with saving any parts of your templates, please reach out to Support for additional instructions.
Posted Aug 29, 2023 - 19:18 PDT
Monitoring
The Engineering team implemented a fix, which should allow customers to save templates once more. If you are still unable to save templates, please reach out to the Support team to receive additional instructions.
Posted Aug 29, 2023 - 17:27 PDT
Investigating
We have received multiple reports that templates cannot be saved. The Engineering team is actively investigating the issue to restore this service. Next update at 5:30 PM PT
Posted Aug 29, 2023 - 16:57 PDT
This incident affected: Global Web Application.