Stuck users across multiple journeys
Incident Report for Iterable
Resolved
All remaining stuck users have been auto-removed from journeys yesterday Tuesday, November 14 and this incident is now resolved. If you need any further assistance related to this incident, please reach out to support for assistance.
Posted Nov 15, 2023 - 09:50 PST
Update
All remaining stuck users have been auto-removed from journeys yesterday Tuesday, November 14 and this incident is now resolved. If you need any further assistance related to this incident, please reach out to support for assistance.
Posted Nov 15, 2023 - 09:47 PST
Update
Our engineering team will continue to process triggered journeys until tomorrow Friday November 10, 12PM (PST). If you need users to be cleared or proceeded, please continue to reach out to your Customer Success Manager (CSM) or support for assistance. Any stuck users remaining will be auto-removed from journeys on Tuesday, November 14.
Posted Nov 09, 2023 - 17:16 PST
Update
Our engineering team has completed proceeding the majority of journeys that required action. We plan to continue working on the remaining affected journeys tomorrow. An update will be scheduled tomorrow 11/09. If you need users to be cleared in the meantime, please reach out to your Customer Success Manager (CSM) or support for assistance.
Posted Nov 08, 2023 - 16:02 PST
Update
Our engineering team worked on proceeding non-scheduled journeys with event triggers today and have completed proceeding most of the journeys of that nature. The next update will be scheduled on 11/08. If you need users to be cleared in the meantime, please reach out to your Customer Success Manager (CSM) or support for assistance.
Posted Nov 07, 2023 - 17:09 PST
Update
Our engineering team restored the transactional data from triggered journeys. The next step is to proceed with most of the stuck users in Non-Scheduled Journeys, starting tomorrow. The next update is scheduled for Tuesday, 11/07. If you continue to experience issues with stuck users on scheduled journeys, please reach out to your Customer Success Manager (CSM) or support for assistance in clearing or proceeding with your users.
Posted Nov 06, 2023 - 19:30 PST
Update
Our engineering team has undertaken the following actions to remediate stuck users.

Stuck Users on Exit Tiles:
These users, who completed their journeys but remained stuck on the last tile, have been cleared from the Journey by engineering.

Users Stuck in Scheduled Journeys:
A majority of stuck users have been cleared from scheduled journeys. If you still are experiencing stuck users, please contact your CSM or support to have your users cleared or proceeded.

Users Stuck in Non-Scheduled Journeys (e.g., custom events, API-triggered, etc.):
Our engineering team is focused on restoring transactional data from triggered journeys. Next update will be provided on Monday, 11/06. If you need users to be cleared or proceeded in the meantime, please contact your CSM or the support team.
Posted Nov 03, 2023 - 11:30 PDT
Update
To address stuck user issues, our engineering team has undertaken the following action items:

Stuck Users on Exit Tiles:
These users, who have completed their journeys but remained stuck on the last tile, have been processed by our engineering team. This action will complete by end of day today 11/02/23

Users Stuck in Scheduled Journeys:
Our engineering team will clear or proceed with stuck users at 3 PM (PST). Please contact your CSM if you wish to have users cleared or moved forward from their journeys by 2:30 PM (PST). Requests submitted after 2:30 PM (PST) will be addressed next week.

Users Stuck in Non-Scheduled Journeys (e.g., custom events, API-triggered, etc.):
Our engineering team will resume efforts on Monday, 11/06, to assess the possibility of retaining transactional data from these journeys. If you need users to be cleared or to proceed in the meantime, please get in touch with your CSM or the support team.
Posted Nov 02, 2023 - 12:40 PDT
Monitoring
Status: Users became stuck in some tiles from 3:42pm to 8:31pm PST on Oct 30th. The issue is now in monitoring status. Visitors after that impact window have been proceeding through journeys as expected. Many of the stuck visitors have completed the journey and falsely appear stuck. CS and Eng have been working through remediation steps. Stuck visitors in scheduled journeys are being resumed/proceeded. Falsely stuck visitors in custom event triggered journeys are also being corrected.

Transactional data cannot be referenced within Journeys with the following trigger types.
- Journey was trigged by custom event or workflow API trigger.
Posted Nov 01, 2023 - 13:59 PDT
This incident affected: Global Web Application.