Mailgun outage disrupting email sends
Incident Report for Iterable
Resolved
Mailgun confirmed their API errors have been fully resolved.
Posted Feb 21, 2022 - 13:14 PST
Monitoring
Mailgun has implemented a fix. We now see Mailgun sends executing successfully and are continuing to monitor.
Posted Feb 21, 2022 - 11:21 PST
Investigating
Mailgun is currently experiencing errors from API endpoints in the US. Organizations utilizing Mailgun are impacted as a result. We are continuing to monitor Mailgun's updates.
Posted Feb 21, 2022 - 10:52 PST