Slow email sends and workflow processing
Incident Report for Iterable
Resolved
We haven't seen any further issues with email sends or workflow processing, so we're going to close this incident. As always, you can open a ticket with us at support@iterable.com if you see anything else unusual. Thank you for your patience.
Posted Oct 17, 2018 - 15:23 PDT
Monitoring
We're no longer seeing email delays, and workflows are also progressing normally. We will continue to monitor the situation.
Posted Oct 17, 2018 - 12:51 PDT
Investigating
We've had reports from some customers about email sends (including proofs) taking longer than expected, as well as workflows processing slowly. Our engineering team is looking at both issues right now, and we'll provide another update by 1:15pm.
Posted Oct 17, 2018 - 12:30 PDT