Users unable to login and web
Incident Report for Iterable
Resolved
The platform has been stable, and users should no longer see any delays on page load or issues logging in. This incident is closed. If you are experiencing any issues, please reach out to Iterable support.
Posted Aug 15, 2024 - 13:47 PDT
Monitoring
We believe the issue has been mitigated and that users should see access returning to normal. We are continuing to monitor. If you are still seeing issues, please contact Iterable support.
Posted Aug 15, 2024 - 09:37 PDT
Update
We are currently investigating multiple reports of users unable to login and slow response in Web UI. Next update before 9:30AM
Posted Aug 15, 2024 - 09:03 PDT
Investigating
We are currently investigating multiple reports of users unable to login and slow response in Web UI. Next update before 9:30AM
Posted Aug 15, 2024 - 09:00 PDT
This incident affected: Global Web Application.