The issues with the Iterable application and API are now resolved and all sends and journeys that may have been delayed during the impact window have now been processed. Please reach out to Support if you continue to experience any issues.
Posted Jul 16, 2026 - 03:07 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 16, 2026 - 02:43 PDT
Identified
Iterable engineering has identified the issue and is currently deployed a fix across the US environment. We are starting to see successful logins on the Iterable application.
Posted Jul 16, 2026 - 02:41 PDT
Investigating
We are currently investigating an issue impacting the main Iterable application in the US region.
Posted Jul 16, 2026 - 02:27 PDT
This incident affected: Global Web Application, Global API Success, Global Links, Global System Webhooks, Global Partner Webhooks, Global Analytics Processing, Global Catalog, Global API Ingestion, Global Campaign Sends, Global Proof Sends, and Global Journey Processing.