Delayed email sends
Incident Report for Iterable
Resolved
Message send rates are back to normal and we are no longer seeing delays in sends. If you have any additional questions please contact your account manager or email support@iterable.com.
Posted Dec 02, 2021 - 09:01 PST
Monitoring
The engineering team has implemented a fix and we see messages being sent at a higher rate. We will continue to monitor this issue to ensure that messages are no longer delayed. The next update will be at 10:00 AM PST if not sooner.
Posted Dec 02, 2021 - 08:01 PST
Update
The engineering team have identified one issue that has affected slow sends but are continuing to investigate other causes. While we investigate we are working on a fix to mitigate the first issue. The next update will be at 9:00 AM PST if not sooner.
Posted Dec 02, 2021 - 07:19 PST
Update
We are continuing to investigate the cause of delayed email sends. Next update at 7:00AM PST
Posted Dec 02, 2021 - 06:00 PST
Investigating
Our engineering team is currently investigating delays in both campaign and proof sends for outbound email. This is affecting multiple clusters. Next update: 6AM PST
Posted Dec 02, 2021 - 05:40 PST
This incident affected: Cluster 6 (Email Sends), Cluster 14 (Email Sends), Cluster 18 (Email Sends), Cluster 16 (Email Sends), Cluster 9 (Email Sends), Cluster 5 (Email Sends), Cluster 10 (Email Sends), Cluster 19 (Emails Sends), Cluster 12 (Email Sends), Cluster 11 (Email Sends), Cluster 15 (Email Sends), Cluster 17 (Email Sends), Cluster 13 (Email Sends), Cluster 8 (Email Sends), Cluster 21 (Email Sends), and Cluster 20 (Email Sends).