InApp message endpoint experiencing elevated error rates
Incident Report for Iterable
Resolved
The getMessages API endpoint has been stable since 5:44pm PST. The Engineering team provisioned additional resources to support the spike in holiday traffic. The added capacity will remain in place throughout the weekend, with continued monitoring through next week. This incident is now resolved. Please reach out to Support if there are further issues.
Posted Dec 22, 2022 - 19:09 PST
Monitoring
The getMessages endpoint success rate has been restored to an acceptable rate and the Engineering team is continuing to monitor the endpoint for stability. Next update by 7:15pm PST.
Posted Dec 22, 2022 - 18:17 PST
Investigating
We are currently experiencing elevated error rates on the getMessages API endpoint. The impact is that users will intermittently not be able to receive and view in-app messages. This will not affect in-app message sends, and users will be able to see the messages upon the next successful getMessages call. The Engineering team is actively investigating and working to restore the endpoint back to health. Next update by 6:15pm PST.
Posted Dec 22, 2022 - 17:18 PST
This incident affected: Global API Success.