Journeys are having issues fetching, creating and saving journeys.

Incident Report for Iterable

Resolved

We do not see any more errors in journey edits.
Posted Mar 07, 2025 - 10:35 PST

Monitoring

A fix has been deployed and journey function is operating normally. Moving to monitoring state.
Posted Mar 07, 2025 - 02:32 PST

Investigating

We are currently investigating an issue affecting Journeys where fetching, creation and saving of journeys is not working correctly. Customers may experience delays or unexpected behavior when using Journeys. Our Engineering team is actively working to identify the root cause.
We will provide the next update in 60 minutes or sooner if more information becomes available.
Posted Mar 07, 2025 - 01:57 PST
This incident affected: Global Web Application.