High API Error Rates
Incident Report for Iterable
Resolved
Push/sms processing returned to normal earlier this morning. This incident is now resolved. Thank you for your patience as we worked through this. If you have any questions please reach out to your CSM or to Support.
Posted Nov 22, 2020 - 10:02 PST
Update
Our engineers are continuing to work on safely resuming push/sms processing. Next update will be tomorrow morning.
Posted Nov 22, 2020 - 00:38 PST
Monitoring
Our engineers have resolved the underlying issue. We are no longer actively having issues with inbound data and API requests, but push/sms messages are not yet being processed as our team continues to remediate the related duplicate send issue. Next update 12:30 am PST.
Posted Nov 21, 2020 - 23:45 PST
Update
Our engineers are continuing to work with our downstream provider to resolve the issue with data ingestion. Some customers have reported seeing duplicate push notifications, and we believe that is related. Next update: 11:45pm PST
Posted Nov 21, 2020 - 22:32 PST
Identified
Our engineers are actively working with one of our downstream providers to resolve an underlying issue with the data ingestion layer. Next update by 10:30 pm Pacific.
Posted Nov 21, 2020 - 21:19 PST
Update
The engineering team is continuing to troubleshoot all aspects of this issue. Next update by 9:15 pm Pacific.
Posted Nov 21, 2020 - 20:18 PST
Investigating
We are currently experiencing high error rates for multiple API endpoints. Our engineering team is investigating and starting remediations.
Posted Nov 21, 2020 - 18:40 PST
This incident affected: Global API.