Issues connecting to app.iterable.com
Incident Report for Iterable
Resolved
Issues connecting to app.iterable.com are now resolved. Please reach out to your Customer Success Manager (CSM) or support if you have any questions or need further assistance.
Posted Nov 22, 2023 - 09:29 PST
Investigating
"Between 7:34 am - 7:43 am pst app.iterable.com had connection issues where customers were not able to access app.iterable.com. This is now working as expected. The engineering team is investigating the issue that caused this. Next update will be provided around 9 am pst."
Posted Nov 22, 2023 - 08:07 PST
This incident affected: Global Web Application.