Journey pages are not responding

Incident Report for Iterable

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 03:59 PDT

Monitoring

Journey pages are loading normally following the fix. Engineering will continue monitoring.
Posted Apr 16, 2026 - 03:45 PDT

Investigating

We’re currently investigating an issue where Journey pages are not responding. Engineering is actively applying a fix and will continue investigating the root cause. Next update at 4:00 PM PST / 11:00 PM GMT.
Posted Apr 16, 2026 - 03:09 PDT