WebApp UI is non-responsive/not loading for a subset of users

Incident Report for Iterable

Resolved

The Engineering team has determined that all metrics are stable, and see no indication of further issues. This incident is resolved. Please reach out to support if you have questions.
Posted Mar 03, 2023 - 13:52 PST

Monitoring

We are no longer seeing users have issue accessing the WebApp.
If you are experience issues, please reach out to support and we will assist you.
Posted Mar 03, 2023 - 09:27 PST

Investigating

We have been receiving reports that the WebApp UI is non-responsive/not loading for a subset of users. Our engineering team is currently investigating the issue.
Next update at 9:30am PST or earlier.
Posted Mar 03, 2023 - 09:07 PST
This incident affected: Global Web Application.