Workflow incorrectly processing users with nested objects.
Incident Report for Iterable
Resolved
Workflow is correctly processing users with nested objects. Thank you for your patience as we worked on this. If you have questions, please reach out to support@iterable.com.
Posted Apr 13, 2021 - 20:54 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2021 - 18:40 PDT
Update
We are continuing work on deploying a fix and should have a resolution soon. Next update at 8 pm PST
Posted Apr 13, 2021 - 18:15 PDT
Identified
Our engineers have identified the underlying cause and are working on a fix. Next update at 6 pm PST
Posted Apr 13, 2021 - 16:55 PDT
Update
Our engineering team is still investigating the incorrect workflow filtering for customers that are using fields of type “nested” in their workflow filter nodes. Next update 4:30pm PDT.
Posted Apr 13, 2021 - 14:32 PDT
Investigating
Engineering is currently investigating incorrect workflow processing for a subset of users involving nested objects.
Next update at 2 pm PDT
Posted Apr 13, 2021 - 12:55 PDT
This incident affected: Cluster 5 (Workflow Processing), Cluster 6 (Workflow Processing), Cluster 8 (Workflow Processing), Cluster 9 (Workflow Processing), Cluster 10 (Workflow Processing), Cluster 11 (Workflow Processing), Cluster 12 (Workflow Processing), Cluster 13 (Workflow Processing), Cluster 14 (Workflow Processing), Cluster 15 (Workflow Processing), Cluster 16 (Workflow Processing), Cluster 17 (Workflow Processing), and Cluster 18 (Workflow Processing).