Increase email bounce rate for Apple domains.
Incident Report for Iterable
Resolved
Our engineering team has finished re-subscribing impacted users and has removed the false unsubscribe events.
The engineering team is now working on post-incident improvements. If you have any further questions please reach out to your Customer Success Manager or submit a ticket to support@iterable.com
Posted Apr 28, 2021 - 12:35 PDT
Update
Our engineering team has re-subscribed the impacted users to all channels, we are now working on a fix to remove a small amount of false unsubscribe events.
Posted Apr 27, 2021 - 12:19 PDT
Update
We are continuing remediation efforts through the evening and will have an update tomorrow morning. If you have any questions, please contact support@iterable.com or your account manager.
Posted Apr 26, 2021 - 21:53 PDT
Update
Our engineering team is continuing work on deploying a solution to update subscriptions and remove the erroneous events stored in Iterable. In order to ensure accuracy, this process will take some time to complete. If you have any questions, please contact support@iterable.com or your account manager. Next update will be at 5 PM PST.
Posted Apr 26, 2021 - 13:53 PDT
Update
As of 12:30 pm PDT, our engineering team has identified all bounces from the Apple outage and is deploying a solution to update subscriptions and remove erroneous events.

Next update at 1:45 pm PDT.
Posted Apr 26, 2021 - 12:44 PDT
Monitoring
Starting at around 7:13 am EDT Apple reported an outage with emails being sent to their domains. Valid email addresses were bounced, this was reported on https://www.apple.com/support/systemstatus/.

Apple has since said that this issue is resolved. We are currently investigating the impact on email sends from Iterable.

Next update at 12:30 pm PDT.
Posted Apr 26, 2021 - 11:17 PDT
This incident affected: Cluster 6 (Email Sends), Cluster 16 (Email Sends), Cluster 11 (Email Sends), Cluster 10 (Email Sends), Cluster 9 (Email Sends), Cluster 18 (Email Sends), Cluster 5 (Email Sends), Cluster 15 (Email Sends), Cluster 13 (Email Sends), Cluster 17 (Email Sends), Cluster 12 (Email Sends), Cluster 14 (Email Sends), and Cluster 8 (Email Sends).