Workflow processing delays
Incident Report for Iterable
Update
Our engineering team is continuing work on reconciling workflow stuck user data to be shared with the subset of impacted customers. We will continue working with these customers directly. If you have any questions please contact support@iterable.com or your account manager.
Posted Feb 23, 2021 - 12:16 PST
Update
The engineering team continues to work on remediating the stuck workflow visitors for the affected customers. If you have any questions about this issue, please email support@iterable.com
Posted Feb 20, 2021 - 13:56 PST
Update
We continue to work with the affected customers on remediating the stuck workflow visitor issue. Next update at 2pm PST.
Posted Feb 20, 2021 - 10:00 PST
Monitoring
Our engineering team is continuing to work with the subset of impacted customers on remediations regarding the stuck workflow visitors. Work will continue through the night with the next update tomorrow at 10 am PST
Posted Feb 19, 2021 - 19:52 PST
Update
Engineering work on the restore process continues to make progress for the impacted customers and workflows. Next update at 6 PM PST
Posted Feb 19, 2021 - 15:34 PST
Update
Work continues to retroactively restore and process the delayed data as well as gather impacted users for affected clients. All new/current workflows continue to operate as normal. Next update at 3 pm PST.
Posted Feb 19, 2021 - 12:22 PST
Update
Work continues to retroactively restore and process the delayed data, all new/current workflows continue to operate as normal. Next update at 12 pm PST.
Posted Feb 19, 2021 - 09:58 PST
Update
Our engineering team is continuing to work on restoring data from older queues. Next update at 10 AM PST.
Posted Feb 19, 2021 - 00:04 PST
Update
Most of the workflows are processing and we have restored most of the data from older queues. Our engineering team is continuing to work on this. Next update at 12 AM PST.
Posted Feb 18, 2021 - 22:22 PST
Update
We have started processing delayed workflow users and our engineering team is monitoring the systems. We appreciate your patience as our engineering team worked on this. If you have questions or concerns, please reach out to your account manager or support at support@iterable.com. Next update at 10 PM PST
Posted Feb 18, 2021 - 20:23 PST
Update
Our engineering team is continuing work on a fix for the delayed workflow users. Next update at 8 PM PST
Posted Feb 18, 2021 - 18:12 PST
Identified
We have identified the underlying issue and have put a fix in place to allow the processing of new workflow visitors for the subset of impacted customers. We are continuing work on a fix to address the current delayed workflow users impacted by the workflow processing delays from earlier today. Next update will be at 6 PM PST
Posted Feb 18, 2021 - 16:11 PST
Update
We are continuing to investigate and make progress on the cause of the workflow processing delays that are impacting a subset of customers. Next update at 4 pm PST
Posted Feb 18, 2021 - 14:07 PST
Investigating
Currently a subset of customers are experiencing workflow processing delays. No data is being lost, only delayed. We are continuing to investigate the underlying cause as well as taking steps to mitigate the issue. Next update at 2 pm PST.
Posted Feb 18, 2021 - 12:48 PST
This incident affects: Workflows.